Amazon is reporting connectivity issues in EU-WEST-2 London Region
Incident Report for MageMojo
Resolved
This incident has been resolved.
Posted 10 days ago. Jan 12, 2019 - 02:27 EST
Identified
There is currently an incident at AWS that is affecting Stratus instances in London, we are waiting for a resolution.

https://status.aws.amazon.com/
Posted 10 days ago. Jan 11, 2019 - 21:28 EST
This incident affected: Mojo Stratus - London.